Javascript ist Toll!

5. May 2010 - 11:19

Linux und Dell Rechner

Heute mal schnell etwas völlig anderes, auf diesem Blog. In erster Linie, damit es auch vielleicht anderen Linux DAUs, die dieses Problem ebenfalls haben, hilft.

Ich habe einen neuen Rechner von Dell und wollte darauf, neben dem bestehenden Windows 7, Ubuntu 10.04 installieren. Dabei gab es zwei Probleme.

Das Erste war relativ leicht lösbar, bzw. ist es eigentlich keines, solange man nicht selber Hand an die Partionierung vom Linuxinstaller legen will. Ich wollte das und plante drei Partitionen. Eine für Windows, eine für Linux und eine für Daten. Die für die Daten, ließ ich bei der ersten Installation weg und wollte sie nachträglich erzeugen. Was ein Fehler war! Denn dadurch wurde ich erst nach der Installation von gparted darauf aufmerksam gemacht, dass ich nur vier primäre Partionen auf eine Festplatte machen darf.

Maximal vier primäre Partitionen

Dumm gelaufen! Dell installiert nämlich drei primäre Partitionen für verschiedene Zwecke und so bleibt nur noch eine übrig. Da ich nicht ein Drittel der Festplatte ungenutzt lassen wollte, blieb mir nichts anderes übrig, als den ganzen Vorgang noch einmal von vorne zu starten. Doch dann begannen erst die eigentlichen Probleme.

Der Rechner bootet nicht mehr

Nachdem ersten einrichten der wichtigsten Programme, wollte ich noch einmal Windows 7 anschauen, um zu sehen, ob dieses noch startet. Dabei gab es keine Probleme. Doch dann, nach einem erneuten Neustart, findet das System keinen Bootsektor mehr. Die kryptische Meldung:

no module name found Aborted. Press any key to exit.

half nicht weiter. Da ich nicht sonderlich bewandert bin, was Linux, Grub und überhaupt Bootloader anbelangt und - nach den ersten Recherchen - Grub wieder neu einzurichten, mir zu kompliziert war. Installierte ich das Linux nun zum dritten mal. Was selbst auf einem aktuellen Rechner relativ lange dauert.

Beim dem ersten Start nach der Linuxinstallation, fragte mich Windows 7 nach einem Update. Der Dell DataSafe oder sowas wäre abgelaufen. Daher vermutete ich das Problem bei dem Update.

Nach dem zweiten Installationsversuch, startete ich Windows 7 erneut. Dieses Mal ohne eine Updatemeldung. Doch nach einem Rechner Neustart das gleiche Spiel, wieder kein Bootlaufwerk :-(

Ursache: Dell DataSafe

Was ist die Ursache für dieses Problem? Nach längeren Suchen stieß ich auf diesen Bugeintrag. Verantwortlich für diesen KuddelMuddel sind die Programme Dell DataSafe Local Backup und Dell DataSafe Local Backup - Support Software! Diese müssen also deinstalliert werden.

Ursache ist, dass dieses Dell DataSafe Programm einen Teil des MBR (Master Boot Record) in dem Grub liegt auf der Festplatte überschreibt.

Restaurierung von Grub?

Das stimmte soweit, als das nach der Deinstallations der Dell Software alles wieder perfekt funktionierte. Nur was ich - vermutlich fehlt mir das nötige Wissen - nicht hinbekam, war die Restaurierung von Grub. Die Befehle auf allen Seiten die ich zu dem Thema fand, funktionierten bei mir nicht. Ich konnte zwar den Bootloader wiederherstellen und kam dann nach dem booten in die Grub Konsole. Aber die Befehle, die auf der Seite weiter unten beschrieben werden, funktionierten bei mir nicht.

Ich habe dann im Endeffekt das Linux zum vierten Mal installiert und hoffe das Dell an ihrer Software arbeitet (wenn das wirklich die Ursache ist) und habe mal wieder gelernt, dass man vorinstallierter Software sehr vorsichtig gegenüber sein sollte, vor allem wenn man nicht weiß was sie tut.

EDIT (6.5.2010): Nachtrag

Ich hab noch ein paar Links gefunden, die sich mit dem Thema Dell DataSafe und Grub auseinandersetzen.

DELL XPS FORUM
In dem Thread wird beschrieben, wie ein Linux auch neben DellDataSafe bestehen kann. Ich hab's nicht genauer durchgelesen, sieht aber aus als ob es unproblematisch wäre. Die Idee scheint zu sein, einfach den MBR auf eine andere Partition zu schreiben.
Boot Problems:Windows Writes To MBR
Es sieht so aus, als ob das nicht nur ein Problem der Dell Software ist. Auch andere Windows Programme schreiben in den Bootsektor. Eklärung und Hilfe findet man auf dieser Seite.

ähnliche Artikel

Comments (3)
595 mal gelesen.

3 Kommentare

Leave a comment »

Seiten:

1. Comment von: detlevs
22. May 2010: 23:47

Hi Struppi,

Und ? Tut der Rechner ?
Ist die Umstellung auf Linux schon vollzogen und Win wird nicht mehr gebootet oder biste noch am kämpfen ?

Ich vermissen das Win nicht.
Nutzte es nur, wenn ich was mit C# mache.

2. Comment von: Struppi
28. May 2010: 12:06

Ich auch nicht.

Seit den hier beschriebenen Problemen habe ich Windows nicht mehr angerührt. Nicht mal eine VM hab’ ich bisher gebraucht.

3. Comment von: Bernd Knorke
13. June 2010: 11:04

Hi,

das Problem habe ich leider auch gerade mit dem Verdammten Dell Rechner……

Vielen Dank für den Blogpost, hat mir sehr geholfen.

Bernd

Leave a comment

Name (required)
Mail (wird nicht angezeigt) (required)
Website

Folgende HTML Tags sind erlaubt: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>



Powered by WordPress Stop Spam Harvesters, Join Project Honey Pot kostenloser Counter Browser-Statistiken
rats-wonderful
rats-wonderful
rats-wonderful
rats-wonderful